E:无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系

发布时间:2017-7-1 11:39:01编辑:www.fx114.net 分享查询网我要评论
本篇文章主要介绍了"E:无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系 ",主要涉及到E:无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系 方面的内容,对于E:无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系 感兴趣的同学可以参考一下。

今天需要ldap的python模块,无法安装
(venv1)root@localhost:~/venv1/bin# apt-get  install libsasl2-dev python-dev libldap2-dev libssl-dev
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
python-dev 已经是最新的版本了。
libssl-dev 已经是最新的版本了。
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
 libldap2-dev : 依赖: libldap-2.4-2 (= 2.4.31-2+deb7u1) 但是 2.4.31-2+deb7u2 正要被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

解决方法如下:


上一篇:按键驱动的恩恩怨怨之同步相互排斥堵塞
下一篇:jQuery效果:简单的手风琴效果

相关文章

相关评论

本站评论功能暂时取消,后续此功能例行通知。

一、不得利用本站危害国家安全、泄露国家秘密,不得侵犯国家社会集体的和公民的合法权益,不得利用本站制作、复制和传播不法有害信息!

二、互相尊重,对自己的言论和行为负责。

好贷网好贷款