Apache+wsgi+flask部署

发布时间:2017-7-1 11:45:39编辑:www.fx114.net 分享查询网我要评论
本篇文章主要介绍了"Apache+wsgi+flask部署 ",主要涉及到Apache+wsgi+flask部署 方面的内容,对于Apache+wsgi+flask部署 感兴趣的同学可以参考一下。

Apache+wsgi+flask部署

flask自带的web server是开发用途,并不适用与发布,需要借助专业的web服务器。

配置的坑无数,Apache部署,403禁止,莫名其妙无法访问,500内部错误把我搞得崩溃了。

重点参考: http://blog.csdn.net/firefox1/article/details/46438769

1.下载

2.解压Apache24,到C:\

3.备份conf\http.conf

4.搜索ServerName,设置,否则启动会提示。测试运行,至少不应报错

5.在服务器浏览器访问http://localhost,应该有 it works,位置是htdocs

6.在配置中搜索DocumentRoot,改为自己要指向的路径,把紧挨着下方的Directory的c:\apache24\htdoc路径改为新的根路径。

用一些静态文件测试,应该能够打开才行。需要重启httpd,需要ie多刷新。

7.将mod_wsgi.so拷贝至C:\Apache24\modules\下,添加如下配置
LoadModule wsgi_module modules/mod_wsgi.so

再次运行httpd,不报错则成功

8.写入wsgi的配置,如

WSGIScriptAlias / c:\XingWeb\web.wsgi

测试运行,应该可以打开python程序

 

——然而,实际情况远比这个复杂:

1、Python可以下到2.7或者3.5的最新版,可以安装。

2、Apache也可以在http://www.apachelounge.com/download/下载,注意左侧有VC版本选择。因为python版本一般较高,所以尽量选高的。

3、mod_wsgi下载:只能用一句mmp来形容,apache需要.so文件,这个so文件要编译而来,而且有多种维度:apache版本,win32/X64,VC版本,Python版本。例如http://www.lfd.uci.edu/~gohlke/pythonlibs/#mod_wsgi中就有

image

但whl怎么搞,要装wheel,要……反正我没搞定

经过一天的折腾,回过头的经验是:1)mod_wsgi一定要保证python大版本一样,小版本尽可能一致,不一致的话,apache的日志会显示,但不影响;2)32/64一定要一致。其他的如vc版本,mod_wsgi本身版本,并不是太影响。

翻遍了网上,太难找了,事实证明有效的两个资源都来自csdn:

http://download.csdn.net/detail/have_no_point/8542823 mod_wsgi3.5的多个版本,对Python2.7而言,对应的是2.7.6

http://download.csdn.net/download/ysahsh/8723423  有mod_wsgi4.4.6的多个版本,对Python2.7而言,对应的是2.7.9+,所以新一些

 

4、运行还是遇到问题,报500错误,日志显示数据库访问出错,开始以为是3.5版太老,找来4.4版,还是一样。

最后找到问题原因,我用到的sqlite路径是相对路径,但apache不认,改为绝对路径,就可以了!

 

折腾一天,除了郁闷和崩溃之外,也对网络中无私奉献自己经验和整理收藏的人心怀感激。



上一篇:Windows10中的IIS10.0安装php manager和IIS URL 重写2.0组件的方法
下一篇:Spring中的类型转换与数据绑定(PropertyEditor、ConversionService、Data Binding、Formatter)

相关文章

相关评论

本站评论功能暂时取消,后续此功能例行通知。

一、不得利用本站危害国家安全、泄露国家秘密,不得侵犯国家社会集体的和公民的合法权益,不得利用本站制作、复制和传播不法有害信息!

二、互相尊重,对自己的言论和行为负责。

好贷网好贷款