jd-gui在Ubuntu上打不开

发布时间:2017-4-28 6:43:58 编辑:www.fx114.net 分享查询网我要评论
本篇文章主要介绍了"jd-gui在Ubuntu上打不开 ",主要涉及到jd-gui在Ubuntu上打不开 方面的内容,对于jd-gui在Ubuntu上打不开 感兴趣的同学可以参考一下。

你在 ubuntu13.10上 安装了最新版本的 jd-gui 但是它跑不起来怎么办?

请执行如下指令:

sudo apt-get install libgtk2.0-0:i386 libxxf86vm1:i386 libsm6:i386 lib32stdc++6

安装细节:

安装过程中的错误:

$ ./jd-gui 
./jd-gui: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory
$ sudo apt-get install libgtk2.0-0:i386
$ ./jd-gui 
./jd-gui: error while loading shared libraries: libXxf86vm.so.1: cannot open shared object file: No such file or directory
$ sudo apt-get install libxxf86vm1:i386
$ ./jd-gui 
./jd-gui: error while loading shared libraries: libSM.so.6: cannot open shared object file: No such file or directory
$ sudo apt-get install libsm6:i386
$ ./jd-gui 
./jd-gui: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory
$ sudo apt-get install lib32stdc++6
$ ./jd-gui 
Gtk-Message: Failed to load module "overlay-scrollbar"
Gtk-Message: Failed to load module "unity-gtk-module"
(jd-gui:4746): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

...现在应该可以运行了。

上一篇:POJ 3723 Conscription(并查集建模)
下一篇:golang高级部分

相关文章

相关评论

本站评论功能暂时取消,后续此功能例行通知。

一、不得利用本站危害国家安全、泄露国家秘密,不得侵犯国家社会集体的和公民的合法权益,不得利用本站制作、复制和传播不法有害信息!

二、互相尊重,对自己的言论和行为负责。

好贷网好贷款