Vim安装jedi-vim提示的一个错误

发布时间:2017-3-23 10:23:10 编辑:www.fx114.net 分享查询网我要评论
本篇文章主要介绍了"Vim安装jedi-vim提示的一个错误 ",主要涉及到Vim安装jedi-vim提示的一个错误 方面的内容,对于Vim安装jedi-vim提示的一个错误 感兴趣的同学可以参考一下。

(仅为了提醒自己)

第一次的安装方法好像是通过 bundle安装的,好像是通过这个安装的并不是最新的版本,然后删除了通过下面的方法,最重要的是要执行 git submodule update --init 才成功的;

安装成功的方法是:

安装pathogen.vim

在~/.vimrc中添加 execute pathogen#infect()

cd ~/.vim/bundle

git clone https://github.com/davidhalter/jedi-vim

cd jedi-vim

git submodule update --init(这一步很重要,我之前的一个错误就是因为没有执行这一句才错的)

jedi-vim 不需要再在.vimrc 中配置什么就可以自动生效了,不过安装jedi-vim 需要注意的是它和其他一些插件的兼容性,比如所vim d的Python-mode;

上一篇:话说Spring Security权限管理(源码)
下一篇:[Ramda] Handle Branching Logic with Ramda's Conditional Functions

相关文章

相关评论

本站评论功能暂时取消,后续此功能例行通知。

一、不得利用本站危害国家安全、泄露国家秘密,不得侵犯国家社会集体的和公民的合法权益,不得利用本站制作、复制和传播不法有害信息!

二、互相尊重,对自己的言论和行为负责。

好贷网好贷款